YDWE

来自咸鱼维基
跳转至: 导航 搜索

YDWE,也称淫荡WE。YDWE是由everguowatalooaerisactboy168SiNgWarft_TigerCNFetrix_sai最萌小汐等人(排名不分先后)从WOW8编辑器中的UI所改进并以月协名义出品的一个功能强大的魔兽地图编辑器增强MOD,其历史意义是让不会Jass的新手能够完成使用Jass才能办到的事情。

YDWE也是一个汉化后的WE,直接使用中文制图,大大降低使用魔兽地图编辑器的门槛。

最新版可以从YDWE的官方博客中确认。

当前的主要维护者为actboy168最萌小汐

稳定版[编辑]

根据收集到的信息,YDWE中,1.31.8、1.29.4、1.27.6是稳定性较高并且较多用户使用的版本。1.30.6正式版是windows xp用户能使用的最终版本。

历代版本[编辑]

你可以在 这里 下载到绝大部分历代YDWE。

1.32[编辑]

版本 类型 更新日期 简介 相关问题
1.32.11 发布帖 正式版 2018-08-20 22:00 [Fix]修正Lua加载模块错误的信息是乱码的问题
[Fix]修正Lua引擎slk库在中文路径下加载失败的问题
[Fix]修正slk优化不支持8进制整数的问题
[Fix]修正地图打包会受到lua环境变量影响的问题
[Fix]修正Lni地图同时存在新旧版本的触发文件时错误的问题
1.32.10 发布帖 正式版 2018-07-21 14:32 [Chg]升级Lua到5.3.5
[Chg]带索引的数据写入非table的值时,会写入第一级
[Fix]修正打开的Lni地图中的数组变量变成常量的BUG
[Fix]修正导入外部文件错误的问题
[Fix]修正UI`发布'全部卸载'命令`不对的问题
[Fix]修正UI`判断触发的事件`无法判断对话框被点击的问题
[Fix]修正slk时公式计算的误差问题
1.32.9 发布帖 正式版 2018-06-21 21:35 [Chg]简化UI`获取自定义值`的文本
[Chg]保存地图时会调用地图插件
[Fix]修正测试前slk优化有处理得不对的问题
[Fix]修正Lni地图测试时会打包两遍的问题
[Fix]修正打开Lni地图会导入无用文件的问题
[Fix]修正测试前Slk地图插件声明的引用失效的问题
补充一点,ydwe1.32内置的w3x2lni的版本是2.4.x。为了确保兼容,ydwe1.32制作的地图最好也是使用w3x2lni 2.4.x。为此,w3x2lni 2.4会是第一个长期维护的版本,直到ydwe1.33正式版发布。今后,w3x2lni的版本策略也会遵循此规则。
1.32.8 发布帖 正式版 2018-06-20 16:42 [New]写物编支持新的api`permanent`可以永久保留生成的对象
[New]UI新增'单位到点的距离'和'单位到点的角度'
[Chg]测试Lni地图可以直接slk,不再需要分为两步
[Chg]UI`夜天自定义代码`加入`不推荐使用`分类
[Chg]UI`夜天运行计时器`加入`不推荐使用`分类
[Chg]UI`[AI]`分类已经并入`[系统]`分类
[Chg]调整逆天UI显示文本
[Chg]调整创建单位和点相关的UI显示文件以及位置
[Fix]修正Lua引擎slk库get_id函数丢失的问题
这是1.32的第一个稳定版本。1.32的主要更新有
1. 支持新的地图格式,Lni地图
2. 支持打开未知的UI的地图(但无法正确保存)
3. 支持测试地图前,自动slk优化
4. 物编生成自动刷新,不再需要重启
5. 游戏数据支持“最新”的选项(实际效果为1.28.5的数据版本)
6. 移除了CJass编译器
7. 大量的细节优化以及Bug修复
1.32.7 发布帖 测试版 2018-06-19 17:31 [New]重写UI`创建永久性尸体`的实现
[New]新的致谢GUI
[Chg]优化泄漏检测报告的输出内容
[Chg]Lua引擎runtime库的version现在是ydwe版本的字符串
[Fix]修正w3m和w3n文件无法保存的问题
[Fix]修正某些情况下无法打包地图的问题
[Fix]修正slk库读取空值会提示读取错误数据的BUG
[Fix]修正物编读写有运行期错误时会影响下一次保存到问题
[Fix]修正UI`等待条件成立`生成的代码不对的问题
[Fix]修正启动局域网测试时有死循环的问题
[Fix]修正局域网测试时,名字有空格或者|导致无法加入游戏的问题
提示:example(演示地图)\系统\系统——泄漏检测.w3x在本版本被更新!YDWE泄漏检测
1.32.6 发布帖 测试版 2018-06-13 15:57 [New]编译地图现在总是使用w3x2lni来打包地图
[New]现在会检测不支持的魔兽版本
[Chg]UI 简化if-then的显示文本
[Chg]UI 收纳盒现在会生成正确的注释
[Chg]移除配置中的兼容模式编译地图(总是被启用)
[Chg]移除了CJass编译器
[Fix]修正include路径计算错误的问题
[Fix]修正几个代码生成的错误
[Fix]修正Lni地图无法测试的问题
[Fix]修正Lni地图不支持tga文件的问题
1.32.5 发布帖 测试版 2018-06-06 17:12 *[New]支持打开和保存为Lni地图
[New]UTF8编码的中文路径文件不再会在保存后被丢弃
[New]优化部分生成的Jass代码
[Chg]逆天触发器/智能导入/预处理器不再会因为开启CJass而被禁用
[Chg]删除了`开启逆天触发器`的配置(总是开启,不能关闭)
[Chg]物编读写现在会显示更多的错误信息
[Fix]修正中心计时器在1.20下无法保存的问题
[Fix]修正中心计时器有些函数没有智能导入的问题
[Fix]修正逆天数组变量的在逆天运行触发器使用无法保存的问题
[Fix]修正逆天变量的在逆天运行触发器某些特殊情形下生成的代码不对的问题
[Fix]修正Lua引擎日志库处理超长日志时会抛错误的问题
*该版本新功能使用提示:
打开Lni地图:双击Lni地图目录下的.w3x文件
普通地图保存为Lni地图(生成5个文件夹+.w3x):另存为,地图文件名改为".w3x"
Lni地图保存为普通地图:另存为,地图文件名改为".w3x"以外的任意名字
YDWE支持新的地图格式
使用旧版本YDWE制作的地图,另存为Lni地图可能会出问题
1.32.4 发布帖 测试版 2018-04-27 21:54 [New] 物品分类增加一个“混杂*真”,以解决原版WE“混杂”分类有错误的bug
[Chg] 编译日志更加友好
[Chg] 继续使用Detours库
[Chg] 对新版本调试器的若干支持
[Chg] 未知UI只会保留最后一次的结果
[Fix] 修正识别未知UI失效的问题
[Fix] 修正1.20生成的逆天代码有错误的问题
[Fix] 修正几个slk优化的错误
[Fix] 修正物编读写的错误
1.32.3 发布帖 测试版 2018-04-03 20:45 [Fix]修正插件加载失败的问题
[Fix]修正Vista无非运行的问题
[Fix]修正调试器和lua引擎的兼容问题
[Fix]修正几个slk优化的错误
1.32.2 发布帖 测试版 2018-04-02 09:49 [New]测试地图时,支持自动将地图slk化
[New]支持Lni格式地图的测试
[New]物编生成现在会自动刷新,不再需要重启
[New]物编生成增加更易用的语法
[New]重写了`新建物体指定ID`的UI
[Chg]调整了UI目录和Jass目录
[Chg]重新整理了物编读写的演示
[Chg]优化了`lua预处理`的速度(约提升10%)
[Chg]`移除地图大小限制`不再是一个插件(总是开启,不能关闭)
[Chg]删除了`触发器自动转码`的配置(总是开启,不能关闭)
[Chg]删除了`显示物体属性内部ID`的功能
[Chg]移除对`Detours`库的依赖
[Chg]移除了几个不常用的菜单
[Chg]StormLib从9.21升级为9.22
1.32.1 发布帖 测试版 2018-02-13 11:06 [New]Lua引擎支持指定调试器的端口号
[Fix]修正颜色插件无法加载的问题
[Fix]修正DX9无法加载的问题
[Fix]修正某些情况下无法正常启动的问题
1.32.0 发布帖 测试版 2018-02-02 17:09 [New]初始化界面重做,现在初始化界面的图片使用UI内的图片。
[New]游戏数据支持“最新”的选项(实际效果为1.28.5的数据版本)。
[New]支持打开未知的UI的地图(但无法正确保存)。
[New]UI文件内置多语言的支持。
[New]Lua引擎现在会默认加载入口文件script/war3map.lua,当使用新的加载方式时,旧的加载方式(使用Cheat)将不可用。
[New]Lua引擎japi库,新增添加japi函数的功能。
[New]Lua引擎部分标准库api支持,package.searchers/package.preload/package.searchpath。
[New]Lua引擎现在所有userdata和table都默认支持gchash机制,不再需要jass.debug.gchash。
[New]Lua引擎的slk库重写,修正了大量的错误并且现在能返回正确的类型。
[New]读写物品字符串支持提示和说明。
[Chg]重写大地图补丁。
[Chg]移除了内置的lua调试器(因为已经不再需要内置)。
[Chg]Lua引擎读文件优化,现在不需要生成临时文件。

1.31[编辑]

从1.31开始,YDWE使用了新的触发器UI格式。

版本 类型 更新日期 简介 相关问题
1.31.8 发布帖 正式版 2017-07-31 21:17 [New] 物便读取可以从技能对象中读取code
[Chg] 物便读取会忽略lni文件
[Chg] 自动清理万能属性用的哈希表数据
[Fix] 修正物编提示会被逗号截断的问题
[Fix] 修正万能属性可能会导致slk优化后出错的问题
lua物编生成问腿
1.31.7 发布帖 正式版 2017-05-17 09:33 [New] Lua引擎新增ai库,包含了所有的native ai函数(但不保证一定可用,就如在jass里一样)
[New] Lua引擎支持在config里使用
[Chg] 本地部署UCRT
[Chg] 更新lua调试器到0.1.0
[Fix] 修正使用了错误版本的CRT的问题
[Fix] 修正虚拟mpq的优先级比地图本身大的问题
[Fix] 修正没有使用物编写入也会重建地图的问题
[Fix] 修正Lua引擎对sleep的处理不正确的问题
[Fix] 修正Lua引擎对超大整数处理不正确的问题
1.31.6 发布帖 测试版 2017-05-04 16:53 [New] Lua引擎支持utf8库和io库的部分函数
[Chg] 优化局域网测试时服务器的启动时间
[Chg] Lua引擎的storm库改用io库实现,并已经被标记为过时的特性
[Fix] 修正物编读取遍历表时Key变成小写的问题
[Fix] 修正部分UI次序不对的问题
[Fix] 修正CRT有时候没有正确加载的问题
[Fix] 修正有时候会保存两次的问题
[Fix] 修正运行触发器UI无法保存的问题
1.31.5 发布帖 测试版 2017-04-01 10:41 [New] 新增11平台的RPG计费UI
[Chg] 给部分物编属性名加上了'%'
[Fix] 修正1.27b无法多人测试的问题
[Fix] 修正注入重复代码的问题
[Fix] 修正修改魔兽路径需要重启编辑器的问题
1.31.4 发布帖 测试版 2017-03-03 10:32 [New] 现在新版本的UI会有[New!]的标签
[New] 替换了WE读取物编数据的流程,以解决War3和WE读取物编数据的不一致行为
[New] 现在编辑器总是使用1.07的物编数据(无论你在地图属性里选了什么,但是地图属性依然影响着你的地图在war3里使用的是什么)
[Chg] 实数转字符串、实数转整数等UI的位置提前
[Chg] UI“按上xx键”现在改为“松开xx键”
[Fix] 修正缺少了蝗虫等若干隐藏技能的问题
[Fix] 修正UI“创建单位(指定点)”中单位面向角度的类型是角度而不是实数的问题
[Fix] 修正UI“是否存有自定义值”最后一个参数错误的问题
[Fix] 修正UI“最后创建的刷兵计时器”返回的值不对的问题
[Fix] 修正局域网测试不支持当使用补丁包的问题
[Fix] 修正局域网测试没有正确关闭服务器的问题
[Fix] 修正pjass不支持多个联系global块的问题
[Fix] 修正pjass会把实数转整数当成returnbug处理的问题
1.31.3 发布帖 测试版 2017-02-28 20:35 [New] 万能属性的物编注入使用新的物编读取重写
[New] 第一次启动时会默认关闭刷子表和不创建新地图
[New] 自动转换不正确的物编数据类型
[New] "能提高护甲的物品"的防御奖励的类型从整数改为实数
[Fix] 修正选取单位内的逆天变量无法保存的问题
[Fix] 修正计时器系统无法保存的问题
[Fix] 修正1.27b部分japi失效的问题
1.31.2 发布帖 测试版 2017-01-19 10:12 [New] 物编读取重写,并增加物编写入功能
[New] 重写逆天UI的生成代码,现在局部变量和其他数据在不同的数据表中
[New] 全新的pjass语法检查器,支持更多的语法错误检查。
[New] 配置程序增加pjass版本的选择
[New] 增加了五个隐藏buff在编辑器的显示,分别是Bsta、Bdbb、BIpb、BIpd、Btlf
[Chg] 移除技能AIlb、AIpb、AIls里的错误数据项
[Chg] ANdo使用魔兽默认的翻译 末日审判 => 魔鬼缠身
[Chg] 移除了grimext插件
[Chg] 移除了'附录'目录
[Chg] 补充几个漏掉的物编文件
[Chg] jass运行时错误检测现在使用中文提示
[Fix] 修正颜色插件没有加载的问题
[Fix] 修正物编读取的演示几个错误的地方
[Fix] 修正UI'单位之间角度'看不到的问题
[Fix] 修正UI'新建区域'看不到的问题
[Fix] 修正UI'最后从物品池里取出的物品'看不到的问题
[Fix] 修正StringHash和新的预处理器不兼容的问题
[Fix] 修正若干没能正确显示注释的UI
[Fix] 修正UI'设置地图限制'的默认值不对的问题
[Fix] 修正jass运行时错误检测在main函数里的错误会导致崩溃的问题

附新旧物编读取的破坏兼容性变化:
1. 移除了factory方法,请用pairs代替(这个方法在旧的slk库里也支持)
slk.unit:factory() => pairs(slk.unit)
2. 所有的整数/实数值都拥有默认值0,旧的slk库是nil
3. 不再转换WESTRING_XXX的字符串,因为魔兽也是不转的
4. 支持同名物编值,例如buttonpos被拆成了buttonpos1和buttonpos2
1.31.1 发布帖 测试版 2016-12-05 10:49 [New] 新的逆天UI,运行触发器
[New] 新的逆天UI,局部变量数组
[New] 新的UI,'发布中介命令'现在支持用技能ID来发布命令
[New] 新的UI,现在命令ID可以转换为无目标、单位目标、点目标命令等
[New] 新的UI,增加了一个昏迷的命令ID
[New] 新的UI,'算术运算Lv3'和'连接字符串 Lv3'
[Chg] '技能[YDWE]'/'特效[YDWE]'/'函数[YDWE]'分类的UI大部分已经被移到'系统[YDWE]'分类,部分移到'单位'分类
[Chg] 简化了YDWE独有UI的分类名,例如'逆天[YDWE]' => '[逆天]'
[Chg] UI中'玩家索引'、'玩家索引号'已经统一改为'玩家ID'
[Chg] UI'玩家索引 [R]'已经改名为'玩家ID - 1 [R]'
[Chg] UI'服务器存档'已经改名为'11RPG存档',UI'RPG积分'已经改名为'11RPG积分'
[Fix] 修正漏了UI'判断当前事件'的问题
[Fix] 修正UI'特效-移动到点'无法保存的问题
[Fix] 修正UI'转换Id为字符串'的默认值不对的问题
[Fix] 修正休眠触发器的演示没有正确运行的问题
[Fix] 修正逆天计时器的演示使用了一些过时写法的问题
[Fix] 修正跟随地图版本的功能有错误的问题
[Fix] 修正物编读取部分值不正确的问题
1.31.0 发布帖 测试版 2016-11-25 22:48 [New] 新的Japi,特效的移动、旋转、缩放、翻转、加速等
[New] 新的Japi,修改单位的移动类型
[New] 新的Japi,修改单位的碰撞类型
[New] 新的Japi,修改单位的面向角度
[New] 新的UI管理器,现在同一分类的UI总是会在一起
[New] 新的UI,四则运算
[Chg] UI分类'Japi'调低了次序
[Chg] UI分类'数学'调高了次序
[Chg] UI分类'特殊效果'改为'特效'
[Fix] 修正设置伤害Japi在1.27下无效的问题
[Fix] 修正保存有只读属性的地图的功能失效的问题
[Fix] 若干提示对话框有错误的问题

1.30[编辑]

本版本亦是最后一个支持在Windows XP上使用的YDWE的版本。

版本 类型 更新日期 简介
1.30.6 发布帖 正式版 2016-11-27 14:08 [Fix] 修正保存有只读属性的地图的功能失效的问题
[Fix] 若干提示对话框有错误的问题
[Fix] 修正休眠触发器的演示没有正确运行的问题
[Fix] 修正逆天计时器的演示使用了一些过时写法的问题
1.30.5 发布帖 正式版 2016-11-16 18:03 [Fix] 修正无法修改字体的问题
[Fix] 修正缺少crt无法启动的问题
[Fix] 修正win10下配置程序里的固定到任务栏会导致启动YDWE的问题
1.30.4 发布帖 测试版 2016-11-06 16:08 [New] 使用stormlib替换JassHelper中sfmpq,提高读写地图的成功率
[New] 新的逆天UI,收纳盒
[Chg] 更新调试器至0.0.12
[Chg] 去掉编码转换的菜单
[Fix] 修正启用调试器后,重开游戏崩溃的问题
1.30.3 发布帖 测试版 2016-10-10 13:21 [New] 新增自动适应当前分辨率的选项(和固定窗口比例互斥)
[New] Lua引擎现在支持使用vscode进行调试
[New] ydwe/jass/native目录下的文件现在会注入地图里,且不会做任何语法检查
[Chg] Lua引擎现在默认关闭sleep
[Chg] Lua引擎读取本地文件现在使用utf8路径
[Fix] 修正Lua引擎gchash计算的一个错误
[Fix] 修正几个japi函数无法保存的问题
[Fix] 修正几个日志库的兼容性问题
1.30.2.Patch1 测试版 2016-08-25 16:15 1.30.2的补丁,不打上补丁就无法正常使用1.30.2。原因是1.30.2在发布时遗漏了BUG,随后被立即修复并发布了这个补丁。
1.30.2 发布帖 测试版 2016-07-18 13:23 [New] Lua引擎增加handle的引用api
[New] Lua引擎现在支持支持任意table和userdata的排序次序(不再是随机)
[New] 补丁包支持加载storm.dll
[New] 若干新的japi和其演示
[Chg] Lua引擎从5.3.1升级到5.3.3
[Fix] 修正Lua引擎读取jass全局数组时崩溃的问题
[Fix] 修正对一个war1.27补丁包的支持的bug
1.30.1 发布帖 测试版 2016-05-09 14:22 [New] Lua引擎从5.2.1升级到5.3.1
[New] Japi现在可以自动帮你计算暗图标
[New] 新的Japi,图标融合
[New] 新的Japi,单位晕眩
[New] 新的Japi,单位变身
[New] 新增11平台的RPG积分UI
[Chg] 启动logo现在会和WE自带的保持一致
[Chg] 虚拟mpq现在支持在配置里指定路径
[Fix] 修正读取技能冷却罕见情况下崩溃的问题
1.30.0 发布帖 测试版 2016-03-15 22:25 [New] 增加对war3 1.27a的支持
[New] Japi支持读写开关技能的图标
[New] Lua引擎支持技能的鼠标事件
[New] Lua引擎支持读取技能按钮数据
[Chg] 日志库重写
[Chg] 去掉对部分boost库的依赖
[Fix] 修正有返回值的发布命令UI失效的问题

1.29[编辑]

版本 类型 更新日期 简介
1.29.4 发布帖 正式版 2016-01-01 19:45 [New] 增加了几个新的注释
[Fix] 修正地形突破器失效的问题
1.29.3 发布帖 正式版 2015-09-18 19:52 [New] Lua引擎新增键盘鼠标消息库
[New] Lua引擎新增发布本地命令库
[New] Lua引擎新增大数库
[New] Lua引擎支持中文路径
[New] Lua引擎增加日志库
[New] 新增智能施法演示
[Chg] Lua引擎在CJ函数崩溃时显示函数名
[Chg] 重写Lua引擎的加载器
[Fix] 修正Lua引擎线程里的错误看不到的问题
1.29.2 发布帖 正式版 2015-07-14 15:37 [New] 新增Japi读写Buff数据
[New] 新增Japi读写Item数据
[New] Lua引擎新增函数jass.debug.current_pos,可以获取当前Jass的运行的位置
[Chg] Lua引擎移除部分不安全的函数
[Chg] Lua引擎修正部分栈泄漏
[Fix] 修正D3D9渲染引擎没有生效的问题
[Fix] 修正魔兽路径有空格时,无法测试的问题
1.29.1 发布帖 正式版 2015-06-05 14:44 [New] 新增插件,去掉地图大小限制
[New] 新增jass.debug的演示
[New] 局域网测试增加多人模式
[Chg] 关闭魔兽后,自动关闭ydhost进程
[Chg] 更新Lua5.3.1
[Chg] 多开插件机制重写,以便支持服务器主机
[Chg] 虚拟mpq现在会在魔兽和编辑器里同时加载war3目录
[Fix] 修正没有清理ydhost进程的问题
[Fix] 修正漏了UI 获取物体属性 (整数) 的问题
[Fix] 修正读取UI文件时没有忽略utf8 bom的问题
[Fix] 修正地形突破器没有生效的问题
[Fix] 修正服务器主机的若干bug
1.29.0 发布帖 正式版 2015-05-25 22:38 [New] 局域网测试支持
[New] 新增创建计时器窗口的UI
[New] Lua引擎,jass.hook库现在可以访问到hook函数
[New] Lua引擎,jass.slk库增加misc表
[New] Lua引擎,新增jass.debug库
[Chg] 禁用JAPI后,会屏蔽JAPI的相关UI
[Chg] Stromlib增加对unicode的支持
[Chg] 字体插件增加对unicode的支持
[Chg] 合并编译时和运行时的物编读取的功能,现在它们的表现会更加接近
[Fix] 修正配置需要重启ydwe才生效的问题

1.28[编辑]

版本 类型 更新日期 简介
1.28.7 发布帖 正式版 2015-06-11 11:30 [Fix] 修正D3D9渲染引擎没有生效的问题
[Fix] 修正配置需要重启ydwe才生效的问题
[Fix] 修正读取UI文件时没有忽略utf8 bom的问题
[Fix] 修正地形突破器没有生效的问题
1.28.6 发布帖 正式版 2015-04-30 15:03 [Fix] 修正不能显示cjass版本信息的问题
[Fix] 修正Lua引擎jass.hook会崩溃的问题
[Fix] 修正逆天计时器有时候会重复传递参数的问题
1.28.5 发布帖 正式版 2015-03-11 17:46 [Chg] Lua引擎Lua版本由5.2.3升级到5.2.4
[Chg] 重写多开插件的IPC方案,减少死锁的情况
[Fix] 修正中文路径无法测试的问题
[Fix] 修正UI地图初始化事件不在第一位的问题
[Fix] 修正部分stormlib函数无法使用的问题
[Fix] 修正版本号没有显示的问题
[Fix] 修正逆天计时器参数传递的错误
[Fix] 修正多开时在某些情况下看不到别人的主机的问题
1.28.4 发布帖 正式版 2015-03-02 17:10 [Chg] 颜色插件默认不开启
[Chg] Lua引擎storm.save现在会创建文件夹
[Fix] 修正部分UI位置混乱的问题
[Fix] 修正部分中文路径处理错误的问题
[Fix] 修正配置程序默认值没有正确处理的问题
[Fix] 修正自定义物体ID错误的问题
[Fix] 修正逆天计时器区域判断错误的问题
1.28.3 发布帖 正式版 2015-02-06 20:44 [Fix] 修正部分中文路径处理错误的问题
[Fix] 修正配置程序没有带出的问题
[Fix] 修正禁用逆天插件时没有禁用逆天UI的问题
[Fix] 修正UI次序混乱的问题
1.28.2 发布帖 正式版 2015-02-05 16:10 [New] 新增颜色插件
[New] 重写UI加载器,现在会用新的方式加载UI。
[New] Lua引擎新增jass.console库
[New] Lua引擎新增部分os库的函数
[Chg] 底层的内部编码由ansi改为unicode
[Chg] StormLib更新到9.11
[Chg] Lua更新到5.3.0
[Chg] Lua引擎storm.load参数编码由ansi改为utf8
[Fix] 修正智能导入没有默认生效的问题
[Fix] 修正暂停腐烂[BJ]选项无效的BUG
[Fix] 修正BJDebugMsg中关于不会被记录在录像中的说明错误
[Fix] 修正疾病伤害的说明错误
[Fix] 修正通魔选项中关于"没有"的说明错误
[Fix] 修正科技的"应用于所有单位"选项的错误(实为"只应用于之后生产的单位")
[Fix] 修正UI"进入指定单位的范围"的限制范围没有起作用的问题
1.28.1 发布帖 正式版 2014-12-19 16:55 [New] 替换NewTesh为Tesh。
[New] Lua引擎增加globals库,用于读/写jass中的全局变量。
[New] Lua引擎common库支持遍历cj函数。
[Chg] Boost更新到1.57。
[Chg] Lua更新到5.3.0(rc1)。
[Chg] CRT更新到msvc120。
[Fix] 修正配置程序中读取中文字体的配置项失败的问题。
[Fix] 修正Lua引擎hook库在多局游戏中没有释放的问题。
[Fix] 修正部分科技的文本没有翻译的问题。
[Fix] 修正“触发单位”等函数在嵌套的逆天计时器中有错误的问题。
1.28.0 发布帖 正式版 2014-08-16 21:20 [New] 全新的TESH,Jass语法高亮插件。
[New] 新增若干JAPI函数。
[Chg] Boost更新到1.56。
[Fix] 修正“触发单位”等函数在嵌套的逆天计时器中有错误的问题。
[Fix] 修正“冲锋”和“月神箭”有结构体释放错误的问题。

其它版本[编辑]

其它版本暂时还没有记录在内,以后想起来了再补。

不过你也可以点击本页面右上角搜索框左边的“编辑”按钮来自行编辑本页面以补充这部分内容。

远古历史[编辑]

大事记[编辑]

2018-06-14 14:29 - 11平台成为YDWE赞助商的消息放出[编辑]

常见问题[编辑]

为什么YDWE的JAPI功能没用?为什么YDWE的获取攻击最大值不管用?[编辑]

 描述:发现只有用ydwe测试的时候才能正常使用这些功能,而用原版war3(1.27)或网易对战平台的时候就不能正常使用(网易对战平台在2018年6月21日后也可以使用了,注意和YDWE的环境仍有差异),比如YDWE的获取单位最大攻击力或护甲值等功能。请问为什么会这样
 回答:YDWE的japi可以在11对战平台魔兽争霸官方对战平台中使用,如果想要其它平台支持只能使用内置JAPI

为什么YDWE的特效JAPI使用设置坐标进行直线位移一段距离后,模型会不显示?[编辑]

 描述:计时器循环0.3秒,设置特效x坐标=特效x坐标+移动距离*cos90,设置特效y坐标=特效y坐标+移动距离*sin90。
 回答:这是bug,而且YDWE作者没有计划去修复。只能中途重新创建特效来解决。题外话:war31.29新出的特效api也有这个bug。不过稍微有点改善,模型显示距离变长了!

ydwe对战平台最大支持多大的地图?[编辑]

 答:4GB来源链接

有什么方法可以解决YDWE的局域网测试功能无法进入地图问题?[编辑]

 答:使用YDWE1.32.11正式版。

为什么AI编辑器无法正常使用?[编辑]

 答:YDWE没有支持AI编辑器。使用World Editor(正常情况下,魔兽争霸3文件夹根目录应该都自带有)和老狼UI来代替。题外话,战役编辑器也可能存在问题来源链接

(jass)在library中无法使用YDWE存储相关的函数[编辑]

 答:library lib requires YDWEBase
     endlibrary

相关工具[编辑]

相关话题[编辑]

相关链接[编辑]